How Do I Install A HP-UX Rule Engine?


Use swinstall to do the following:

  1. Logon to the HP-UX machine as ‘root‘.
  2. If this is a fresh install, then go to step 6.
  3. If an older version is installed, stop the daemon by running:

    ag_re -stop

  4. Verify the Unix Rule Engine stops by checking:

    ps -e | grep ag_re

  5. Use swremove to remove the existing installation. Enter:

    swremove ARGTre

  6. Ensure the installation path is in the environment variable PATH

    PATH=”${PATH}:/opt/Argent/UNIX”

    export PATH

    This should be done in /etc/profile to ensure the PATH is properly defined at all times.

  7. Place ARGENT_UNIX_RULE_ENGINE_yymm_HPUX_DEPOT.TAR.Z in the root directory ‘/
  8. Change to the root directory ‘/‘. Enter:

    cd /

  9. Uncompress by running:

    uncompress ARGENT_UNIX_RULE_ENGINE_yymm_HPUX_DEPOT.TAR.Z

  10. Use swinstall to install the depot. Enter:

    swinstall -x ask=true -s /ARGTre.depot ARGTre

    Enter the IP address or fully qualified domain name of the main engine when prompted.

  11. If this Unix Rule Engine only monitors itself, go to step 20.
  12. If this machine does not have OpenSSH installed, install it. The monitored Unix machines should have OpenSSH installed as well.
  13. See Also: How Do I Set Up SSH Equivalence to configure an account that can SSH into other Unix machines without password.
  14. Edit ag_re.opt to specify the SSH binary path in the section “SSH bin path” if the binaries are not in the PATH.
  15. Create group ‘argentguardian‘ and add the su account to the group. For more information about creating groups, See Also: How Do I Create A Unix Group
  16. To make all the files and directories belong to group ‘argentguardian‘, Run:

    chgrp -R argentguardian /opt/Argent

  17. Run:

    chmod 0770 /opt/Argent

    chmod -R 0770 /opt/Argent/UNIX

    chmod 0660 /opt/Argent/UNIX/ag_re.opt

  18. Each directory under /opt/Argent should also have the “group sticky-bit” set to ensure that all files created are members of the group ‘argentguardian‘. This is done using:

    find /opt/Argent -type d -exec chmod g+t {} \;

  19. If this Unix Rule Engine will be used to monitor other systems, the startup file /sbin/init.d/ArgentRuleEngine must be edited to provide the proper credentials for the su account.

    Change the line in the “start” section that reads /opt/Argent/UNIX/ag_re -start to this:

    su – USERNAME -c “/opt/Argent/UNIX/ag_re -start”

    Replace USERNAME with the su account name.

  20. Start the Unix Rule Engine:

    /sbin/init.d/ArgentRuleEngine start

    If the Unix Rule Engine will only monitor itself, enter:

    ag_re -start

  21. Verify ag_re and ag_re_main start up by running:

    ps -e | grep ag_re

  22. Read the /opt/Argent/UNIX/logs/log.txt to verify the communication is successful.

If the Unix Rule Engine will be used to monitor other systems, this file must be edited prior to starting the Unix Rule Engine. See step 19 for details.

After installing the depot, the daemon service for the Unix Rule Engine is already configured to start automatically when the system boots. The depot installs ArgentRuleEngine in /sbin/init.d.

When the production schedule permits, reboot the machine to verify that the Unix Rule Engine starts successfully.




#!/bin/sh

#

#

# Copyright (c) 2007 ArgSoft Intellectual Property Holdings, Limited

#

# All Rights Reserved.

#

# ArgSoft Intellectual Property Holdings, Limited

# Canon's Court

# 22 Victoria Street

# Hamilton

# Bermuda HM12

#

#

# This is PROPRIETARY SOURCE CODE of ArgSoft Intellectual Property Holdings, Limited.

#

# The contents of this file may not be disclosed to third parties, copied or

# duplicated in any form, in whole or in part, without the prior written

# permission of ArgSoft Intellectual Property Holdings, Limited.

#

# RESTRICTED RIGHTS LEGEND:

# Use, duplication or disclosure by the Government is subject to restrictions

# as set forth in subdivision (c)(1)(ii) of the Rights in Technical Data

# and Computer Software clause at DFARS 252.227-7013, and/or in similar or

# successor clauses in the FAR, DOD or NASA FAR Supplement.

#

# Unpublished - rights reserved under the Copyright Laws of the United States

# and other countries.

#



PATH="$PATH:/opt/Argent/UNIX"

export PATH



case "$1" in

'start')

        if [ -f  "/opt/Argent/UNIX/ag_re" ]; then

                echo 'Argent Unix Rule Engine service starting.'

                su - USERNAME -c "/opt/Argent/UNIX/ag_re -start"

        fi

        ;;

'stop')

        if [ -f  "/opt/Argent/UNIX/ag_re" ]; then

                echo 'Argent Unix Rule Engine service stopping.'

                /opt/Argent/UNIX/ag_re -stop

        fi

        ;;

*)

        echo "Usage: $0 { start | stop }"

        exit 1

        ;;

esac.